Facebook HHVM 缓冲区错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1949113 漏洞类型 缓冲区错误
发布时间 2020-03-03 更新时间 2020-03-13
CVE编号 CVE-2020-1888 CNNVD-ID CNNVD-202003-146
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-202003-146
|漏洞详情
Facebook HHVM(又名HipHop Virtual Machine)是美国Facebook公司的一款能够显著提高PHP加载动态页面性能的虚拟机。 Facebook HHVM中存在缓冲区错误漏洞,该漏洞源于程序在handleBackslash中解码JSON时没有正确检查边界。攻击者可利用该漏洞导致拒绝服务。以下产品及版本受到影响:Facebook HHVM 4.45.0版本,4.44.0版本,4.43.0版本,4.42.0版本,4.41.0版本,4.40.0版本,4.39.0版本,4.33.0版本至4.38.0版本,4.9.0版本至4.32.0版本,4.8.7之前版本。
|参考资料

来源:CONFIRM

链接:https://hhvm.com/blog/2020/02/20/security-update.html


来源:CONFIRM

链接:https://github.com/facebook/hhvm/commit/b3679121bb3c7017ff04b4c08402ffff5cf59b13


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2020-1888