OAuth2 Proxy 输入验证错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 2018713 漏洞类型 输入验证错误
发布时间 2020-05-07 更新时间 2020-08-21
CVE编号 CVE-2020-11053 CNNVD-ID CNNVD-202005-301
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-202005-301
|漏洞详情
OAuth2 Proxy是一款能够提供与Google、Github或其他提供商进行身份验证的反向代理。 OAuth2 Proxy 5.1.1之前版本中存在输入验证错误漏洞。攻击者可借助特制的重定向URL利用该漏洞绕过验证并将用户重定向到所提供的任意URL上。
|参考资料

来源:CONFIRM

链接:https://github.com/oauth2-proxy/oauth2-proxy/security/advisories/GHSA-j7px-6hwj-hpjg


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2020-11053