Sabberworm PHP CSS Parser 安全漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 2049788 漏洞类型 输入验证错误
发布时间 2020-06-03 更新时间 2020-08-12
CVE编号 CVE-2020-13756 CNNVD-ID CNNVD-202006-322
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-202006-322
|漏洞详情
PHP(PHP:Hypertext Preprocessor,PHP:超文本预处理器)是PHPGroup和开放源代码社区的共同维护的一种开源的通用计算机脚本语言。该语言主要用于Web开发,支持多种数据库及操作系统。 Sabberworm PHP CSS Parser 8.3.1之前版本中存在输入验证错误漏洞。远程攻击者可借助‘allSelectors’或‘getSelectorsBySpecificity’函数利用该漏洞在系统上执行任意代码。
|参考资料

来源:MISC

链接:https://packetstormsecurity.com/files/157923/Sabberworm-PHP-CSS-Code-Injection.html


来源:MISC

链接:https://github.com/sabberworm/PHP-CSS-Parser/commit/2ebf59e8bfbf6cfc1653a5f0ed743b95062c62a4


来源:MISC

链接:https://github.com/sabberworm/PHP-CSS-Parser/releases/tag/8.3.1


来源:MISC

链接:http://seclists.org/fulldisclosure/2020/Jun/7


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2020-13756


来源:packetstormsecurity.com

链接:https://packetstormsecurity.com/files/157923/Sabberworm-PHP-CSS-Code-Injection.html