FFmpeg 缓冲区错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 2059517 漏洞类型 缓冲区错误
发布时间 2020-06-16 更新时间 2020-07-29
CVE编号 CVE-2020-14212 CNNVD-ID CNNVD-202006-1122
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-202006-1122
|漏洞详情
FFmpeg是FFmpeg团队的一套可录制、转换以及流化音视频的完整解决方案。 FFmpeg 4.3及之前版本中的libavformat/aviobuf.c文件的avio_get_str存在缓冲区错误漏洞,该漏洞源于程序没有进行正确的边界检查。远程攻击者可利用该漏洞在系统上执行任意代码或导致应用程序崩溃。
|参考资料

来源:MISC

链接:https://trac.ffmpeg.org/ticket/8716


来源:MISC

链接:https://patchwork.ffmpeg.org/project/ffmpeg/list/?series=1463


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2020-14212