LibRaw 缓冲区错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 2071685 漏洞类型 缓冲区错误
发布时间 2020-06-28 更新时间 2020-07-02
CVE编号 CVE-2020-15365 CNNVD-ID CNNVD-202006-1772
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-202006-1772
|漏洞详情
LibRaw是LibRaw团队的一个用来处理RAW(CRW/CR2、NEF、RAF、DNG和others)格式图片的C++库。 LibRaw 0.20-Beta3之前版本中的metadataexif_gps.cpp文件的‘parse_exif()’函数存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。
|参考资料

来源:MISC

链接:https://github.com/LibRaw/LibRaw/compare/0.20-Beta2...0.20-Beta3


来源:MISC

链接:https://github.com/LibRaw/LibRaw/issues/301


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2020-15365