GNU LibreDWG 资源管理错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 2091809 漏洞类型 代码问题
发布时间 2020-07-16 更新时间 2020-07-30
CVE编号 CVE-2019-20909 CNNVD-ID CNNVD-202007-1176
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-202007-1176
|漏洞详情
GNU LibreDWG是GNU计划的一个用于处理DWG文件的C语言库。 GNU LibreDWG 0.9.3及之前版本中的dwg.spec文件的‘dwg_encode_LWPOLYLINE’函数存在代码问题漏洞。攻击者可借助特制DWG文件利用该漏洞导致应用程序崩溃(拒绝服务)。
|参考资料

来源:MISC

链接:https://github.com/LibreDWG/libredwg/commit/d7913b893bfa98fab27f05825dc4cab2d3a20c83


来源:MISC

链接:https://github.com/LibreDWG/libredwg/issues/178


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2019-20909