bsdiff4 缓冲区错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 2097849 漏洞类型 缓冲区错误
发布时间 2020-07-22 更新时间 2020-08-03
CVE编号 CVE-2020-15904 CNNVD-ID CNNVD-202007-1389
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-202007-1389
|漏洞详情
bsdiff4是一款用于构建修补程序并将其应用于二进制文件的库。 bsdiff4 1.2.0之前版本中的修补程序存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。
|参考资料

来源:MISC

链接:https://github.com/ilanschnell/bsdiff4/commit/49a4cee2feef7deaf9d89e5e793a8824930284d7


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2020-15904