JerryScript 缓冲区错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 2120546 漏洞类型 缓冲区错误
发布时间 2020-08-13 更新时间 2020-08-17
CVE编号 CVE-2020-24345 CNNVD-ID CNNVD-202008-758
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-202008-758
|漏洞详情
JerryScript是JerryScript项目的一款轻量级的JavaScript引擎。 JerryScript 2.3.0及之前版本中的ecma_is_lexical_environment存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。
|参考资料

来源:MISC

链接:https://github.com/jerryscript-project/jerryscript/issues/3977


来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2020-24345