Apache OpenOffice RCE(CVE-2020-13958)漏洞预警

阅读量    161366 |

分享到: QQ空间 新浪微博 微信 QQ facebook twitter

 

Apache OpenOffice 4(包括经过测试的最新版本4.1.7)容易受到远程代码执行的攻击; 如果受害者在Windows上打开了精心制作的.odt文档,则攻击者可以完全控制他们的计算机。

漏洞问题是,该产品无法像宏执行一样处理script:event-listener处理程序。

使用这样的构造:

<office:scripts>
<office:event-listeners>

<script:event-listener script:language="ooo:script" xlink:href=".uno:OpenHyperlinkOnCursor" script:event-name="dom:load"/>
</office:event-listeners>
</office:scripts>

在OpenOffice中,无需任何确认对话框即可触发打开URL,包括专门供内部使用的特殊.uno或.service链接处理程序。

PoC可以在Windows上弹出计算器。 还支持UNC目标,在这种情况下,它们受操作系统的“网络标记”安全警告的约束。

触发.uno或.service动作在Linux上也能正常工作-尽管找不到将其转变为在该OS上执行代码的实用方法。

受影响的版本

Apache OpenOffice 4 versions before 4.1.8.

参考链接:https://github.com/irsl/apache-openoffice-rce-via-uno-links

分享到: QQ空间 新浪微博 微信 QQ facebook twitter
|推荐阅读
|发表评论
|评论列表
加载更多