CVE-2022-24706:Apache CouchDB 远程代码执行漏洞通告

阅读量    140822 |

分享到: QQ空间 新浪微博 微信 QQ facebook twitter

 

0x01   漏洞简述

2022年04月27日,360CERT监测发现Apache官方发布了Apache CouchDB的风险通告,漏洞编号为CVE-2022-24706,漏洞等级:高危,漏洞评分:7.8

CouchDB 是一个开源的面向文档的数据库管理系统,可以通过 RESTful JavaScript Object Notation (JSON) API 访问。

对此,360CERT建议广大用户及时将Apache CouchDB升级到最新版本。与此同时,请做好资产自查以及预防工作,以免遭受黑客攻击。

 

0x02   风险等级

360CERT对该漏洞的评定结果如下

评定方式 等级
威胁等级 高危
影响面 广泛
攻击者价值
利用难度
360CERT评分 7.8

 

0x03   漏洞详情

CVE-2022-24706: Apache CouchDB代码执行漏洞

CVE: CVE-2022-24706

组件: Apache CouchDB

漏洞类型: 代码执行

影响: 服务器接管

简述: 由于CouchDB的默认安装配置存在缺陷,未授权的远程攻击者可以通过访问特定端口,绕过权限验证并获得管理员权限,最终接管服务器。

 

0x04   影响版本

组件 影响版本 安全版本
Apache CouchDB >= 3.2.2

 

0x05   修复建议

通用修补建议

根据影响版本中的信息,排查并升级到安全版本

临时修补建议

1. 在安装CouchDB前设置防火墙。完整的CouchDB api 在注册端口“5984”上可用,这是唯一的需要为单节点安装公开的端口。

2. 强制修改CouchDB 3.2.2 及更高版本中默认的 Erlang cookie 值,并将所有 CouchDB 分发端口绑定到本地IP地址(注意不能是 0.0.0.0)。

 

0x06   产品侧解决方案

若想了解更多产品信息或有相关业务需求,可移步至http://360.net。

360安全分析响应平台

360安全大脑的安全分析响应平台通过网络流量检测、多传感器数据融合关联分析手段,对该类漏洞的利用进行实时检测和阻断,请用户联系相关产品区域负责人获取对应产品。

360安全卫士

Windows用户可通过360安全卫士实现对应补丁安装、漏洞修复、恶意软件查杀,其他平台的用户可以根据修复建议列表中的安全建议进行安全维护。

360CERT建议广大用户使用360安全卫士定期对设备进行安全检测,以做好资产自查以及防护工作。

360安全卫士团队版

用户可以通过安装360安全卫士并进行全盘杀毒来维护计算机安全。360CERT建议广大用户使用360安全卫士定期对设备进行安全检测,以做好资产自查以及防护工作。

360本地安全大脑

360本地安全大脑是将360云端安全大脑核心能力本地化部署的一套开放式全场景安全运营平台,实现安全态势、监控、分析、溯源、研判、响应、管理的智能化安全运营赋能。360本地安全大脑已支持对相关漏洞利用的检测,请及时更新网络神经元(探针)规则和本地安全大脑关联分析规则,做好防护。

 

0x07   时间线

2022-04-26 Apache官方发布通告

2022-04-27 360CERT发布通告

 

0x08   参考链接

1、 https://lists.apache.org/thread/w24wo0h8nlctfps65txvk0oc5hdcnv00

2、 https://www.mail-archive.com/announce@apache.org/msg07264.html

3、 https://docs.couchdb.org/en/stable/setup/cluster.html

分享到: QQ空间 新浪微博 微信 QQ facebook twitter
|推荐阅读
|发表评论
|评论列表
加载更多