CVE-2024-1403:Progress Software 中新的备受瞩目的漏洞

阅读量28652

发布时间 : 2024-03-13 10:22:00

CVE-2024-1403:Progress Software 中新的备受瞩目的漏洞。

在信息安全领域, 已发现一个影响Progress Software 产品的严重漏洞,特别是 OpenEdge Authentication Gateway 和 AdminServer。此漏洞对身份验证机制构成严重威胁,可能允许攻击者绕过安全措施并获得对系统的未经授权的访问。

该问题被标识为 CVE-2024-1403,其严重程度最高, CVSS 评分为 10 。该漏洞影响 OpenEdge 11.7.18 及之前版本、12.2.13 及更早版本以及 12.8.0。

问题在于,当OpenEdge Authentication Gateway (OEAG)配置为使用本地操作系统认证系统对用户进行认证时,认证机制存在缺陷。通过 OpenEdge Explorer 和 OpenEdge Management(也使用本地身份验证)连接到 AdminServer 时,也会出现类似的问题。

据 Progress Software 称,当系统错误地解释意外类型的用户名和密码,导致登录时未经过适当的凭据验证时,就会出现此问题。因此,攻击者可以绕过身份验证过程,获得对受保护资源的访问权限。

该公司已采取措施消除该漏洞,发布了 OpenEdge LTS 更新 11.7.19、12.2.14 和 12.8.1。强烈建议用户安装这些更新以保护其系统免受潜在攻击。

Horizo​​n3.ai 研究团队 通过实施和发布 PoC 漏洞为该漏洞的研究做出了贡献。该团队的专家发现,问题的根源与远程连接期间激活的“connect()”函数有关。该函数调用另一个函数“authorizeUser()”,该函数的作用是检查提供的数据是否满足给定的条件。但是,如果用户名与“NT AUTHORITY\SYSTEM”匹配,则会发生直接授权,绕过必要的检查。

此外,研究人员还指出了进一步攻击的可能性,例如通过 WAR 文件的远程链接部署新应用程序。

此前,Progress Software已卷入IT行业重大丑闻,其子公司Ipswitch的MFT客户端MoveIT Transfer遭 Clop黑客攻击, 导致各领域数百家公司被攻陷,总经济损失数十亿美元。

CVE-2024-1403 的发现以及过去对 Progress Software 的备受瞩目的攻击凸显了保持软件最新的重要性以及网络安全警惕的必要性。企业和消费者应采取一切必要的预防措施,保护其系统免受潜在威胁并确保数据安全。

本文转载自: https://www.securitylab.ru/news/546688.php

如若转载,请注明出处:

安全客 - 有思想的安全新媒体

分享到:微信
+13赞
收藏
安全客
分享到:微信

发表评论

内容需知
  • 投稿须知
  • 转载须知
  • 官网QQ群8:819797106
  • 官网QQ群3:830462644(已满)
  • 官网QQ群2:814450983(已满)
  • 官网QQ群1:702511263(已满)
合作单位
  • 安全客
  • 安全客
Copyright © 北京奇虎科技有限公司 360网络攻防实验室 安全客 All Rights Reserved 京ICP备08010314号-66