CVE-2020-3943: vmware vRealize 远程代码执行漏洞通告

阅读量    20351 |

分享到: QQ空间 新浪微博 微信 QQ facebook twitter

 

0x01 漏洞背景

2020年02月22日, 360CERT监测发现 vmware 官方发布了编号为 VMSA-2020-0003 的安全更新。其中有一例严重漏洞, CVE 编号为 CVE-2020-3943。该漏洞出现在 vRealize 组件在实现和 Horizon 组件进行协作的时候,该协作程序启用了不安全的 JMX RMI 服务,进而导致任意代码执行漏洞的出现。

VMware vRealize Suite 是专为混合云而构建的云管理平台。

VMware Horizon 是由 vmware 公司推出的一款针对Windows、Linux及Mac OS X,所开发的虚拟桌面软件。

JMX(Java Management Extensions,即Java管理扩展)是Java平台上为应用程序、设备、系统等植入管理功能的框架。JMX可以跨越一系列异构操作系统平台、系统体系结构和网络传输协议,灵活的开发无缝集成的系统、网络和服务管理应用。

 

0x02 风险等级

360CERT对该漏洞进行评定

评定方式 等级
威胁等级 高危
影响面 一般

360CERT建议广大用户及时更新 vRealize Operations for Horizon Adapter。做好资产 自查/自检/预防 工作,以免遭受攻击。

 

0x03 影响版本

vRealize Operations for Horizon Adapter <= 6.6.0

vRealize Operations for Horizon Adapter <= 6.7.0

 

0x04 修复建议

更新 vRealize Operations for Horizon Adapter 至

  • 6.6.1
  • 6.7.1

由于核心问题产生在 JMX RMI 服务上,用户可以在针对Java运行时环境检测 com.sun.management.jmxremote.port,并对相应的端口通信进行限制以缓解漏洞所带来的影响。

 

0x05 时间线

2020-02-18 vmware发布安全公告

2020-02-22 360CERT发布预警

 

0x06 参考链接

  1. VMSA-2020-0003
分享到: QQ空间 新浪微博 微信 QQ facebook twitter
|推荐阅读
|发表评论
|评论列表
加载更多